We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Unable to change hostname on dedicated server


WebHostingNeeds
2016-11-10, 11:43 AM
Verify host name with command

Code:
hostname
That message you get when login is is just /etc/motd, you can empty that file if you don't need it. It is more of an OVH added thing

Code:
echo > /etc/motd

scsa20
2016-11-09, 03:08 PM
If you're using Plesk for managing your server then you do not want to make any changes directly to the files from SSH since it's just going to get overwritten by Plesk. Instead, you'll want to go to Tools & Settings within Plesk, click on Server Settings and then change the name under "Full hostname" to officially change the host name.

Also, how did you issued the SSL cert from Let's Encrypt? Cause what you're seeing is the default self signed cert that gets generated automatically.

And no the NS record has nothing to do with the host name or cert signing as the NS record just tells DNS servers where to go to get your DNS records.

kcgatsby
2016-11-09, 12:33 PM
Hi guys,

I've been having issues on changing the hostname on my dedicated OVH. I added reverse to the IP, changed hostname in /etc/hostname and /etc/sysconfig/network and rebooted the server. But when I login through SSH it still shows the ns123456.ip-xxx-xxx-xxx.net instead of host.myserver.com.

Also, when issuing SSL certificate from Plesk with Let's Encrypt, it shows the ns123456.ip-xxx-xxx-xxx.net on every single domain that I have and I am unable to issue the ssl certificate.

Here's what it shows when I login to the server through ssh:
Code:
CentOS Linux release 7.2.1511 (Core) 

Linux ns123456.ip-xxx-xxx-xxx.net 3.14.32-xxxx-std-ipv6-64 #9 SMP Thu Oct 20 15:08:27 CEST 2016 x86_64 x86_64 x86_64 GNU/Linux

server    : 123456
hostname  : ns123456.ip-xxx-xxx-xxx.net
eth0 IPv4 : xxx.xxx.xxx.xxx
eth0 IPv6 : xxxx.xxxx.xx.xxxx::/64
But when doing cat /etc/hostname it shows my shost name.

here's what cat /etc/sysconfig/network looks like:

Code:
# Created by anaconda
NOZEROCONF=true
GATEWAY=xxx.xxx.xxx.xxx
HOSTNAME=host.myserver.com
NETWORKING_IPV6=yes
and hostnamectl status:

Code:
Static hostname: host.myserver.com
         Icon name: computer-server
           Chassis: server
          Location: OVH bhsx, Canada
        Machine ID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
           Boot ID: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
  Operating System: CentOS Linux 7 (Core)
       CPE OS Name: cpe:/o:centos:centos:7
            Kernel: Linux 3.14.32-xxxx-std-ipv6-64
      Architecture: x86-64
Here's what it shows on plesk under hosting settings:
https://s16.postimg.org/8i35km7tx/Sc...13_37_AM_3.png

Also I noticed that the ns record shows sdns1.ovh.ca. and ns123456.ip-xxx-xxx-xxx.net. Is that's what's causing the issues?

I called OVH and they said they can't can't provide software support. At this point I don't know what else to do to fix this.

Any help would be greatly appreciated as I am trying to moved away from my current host.

Thank you!