We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problem with receiving email (ERROR 550: Recipient not found)


Zarko
2016-04-28, 01:46 PM
It turns out that I used wrong MX records (smtp.secureserver.net) instead of mine. It came to me just after I answered to your post. I guess thanks for asking the right question

case closed

Zarko
2016-04-28, 11:36 AM
Hi scsa20, thanks for your reply.

The email server is self hosted on my vps. Postfix

scsa20
2016-04-28, 11:07 AM
That error is stating that there's no mailbox for zarun@oac-online.com. You use godaddy for your email service? If so which email plan? (basic email, exchange, office 365 email?)

24x7servermanagement
2016-04-28, 03:05 AM
Its not only with Gmail but with other SMTP server as well getting the same error.. Looks like the email address is not setup correctly.

SMTP session

[Resolving smtp.secureserver.net...]
[Contacting smtp.secureserver.net [68.178.213.37]...]
[Connected]
220 p3plibsmtp02-11.prod.phx3.secureserver.net bizsmtp ESMTP server ready
EHLO mx1.validemail.com
250-p3plibsmtp02-11.prod.phx3.secureserver.net hello [208.101.20.91], pleased to meet you
250-HELP
250-SIZE 104857600
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-STARTTLS
250 OK
MAIL FROM:<>
250 2.1.0 <> sender ok
RCPT TO:
550 5.1.1 Recipient not found.
[Address has been rejected]

Zarko
2016-04-23, 06:25 AM
First of all thanks for providing such a great service at affordable prices. Since this is my first post on the forum, I'd like to say that I'm really pleasantly satisfied with hosting on OVH.

Now the getting to point part.
I rented the VPS machine, and tried to setup services manually in order to use as low as possible process and memory resource on the machine.
I setup LAMP successfully, along with postfix and dovecot for mail server. My mail client successfully connects to the account and test message wents OK. However, it turns out that I can send email, but can't receive it from anyone else besides myself.

At first I thought it was something I did wrong with the manual configuration, so I did a clean VPS reinstall, and ran a Sentora automated package. This didn't resolve the problem:

Code:
Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain oac-online.com by smtp.secureserver.net. [68.178.213.203].

The error that the other server returned was:
550 5.1.1  Recipient not found.  
So I went a step further, paying a closer attention to this error message, I figured it probably might have something to do with my MX records on the domain registar. My domain is registered at godaddy, and I didn't (find need to?) do DNS transfer to ovh.

Below is my domain configuration:
http://s31.postimg.org/3n40tdmdn/godaddy.png

I changed MX records smtp.secureserver.net to smtp.europe.secureserver.net and mailstore1.secureserver.net to mailstore1.europe.secureserver.net but that din't do any difference either.

Now I'm running out of ideas. Any help would be appreciated.